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1 Introduction

VirusMapper is provided under the form of the NanoJ-VirusMapper ImageJ plugin,
an open-source analytical framework that combines super-resolution (SR) imaging and
näıve Single Particle Analysis to generate unbiased structural models of virus architec-
ture.

This manual is for anyone who wants to use VirusMapper to produce models of vi-
ral architecture using their own data. The process, which is described in detail in the
paper and supplementary information, is here outlined step by step. A sample dataset
is also included to allow users to practise, described in Section 6.

This manual was produced using VirusMapper release version 1.0R5 running in Fiji
with ImageJ1.51d. Testing was done on both Mac and Windows (both 64 bit) with Java
version 1.8.

2 Getting started

Installation

VirusMapper is a plugin to ImageJ or Fiji. ImageJ can be downloaded from http:

//imagej.nih.gov/ij/download.html. Fiji can be downloaded from http://fiji.

sc/Downloads#Fiji.
There are two ways to install VirusMapper with Fiji but only the first will work with
ImageJ.

1. Copy jars directly - ImageJ or Fiji

VirusMapper accompanies this manual. To install it for the first time, open the
ImageJ plugins folder and copy all of the .jar files into the Plugins subfolder in
your ImageJ or Fiji. To access this on Mac, find Fiji in your Applications folder,
right click and select Show Package Contents.

Alternatively, visit https://bitbucket.org/rhenriqueslab/nanoj-virusmapper/
wiki/Home to download the latest version of VirusMapper.
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2. Add update sites - Fiji only

In Fiji, select Help→Update Fiji. After the Checksummer has run, a window
should appear. This may show items to update but this will not affect NanoJ
installation.

Select “Manage update sites”. Another window will appear. Select “Add my
site”. In the next window, enter “NanoJ” into the “ImageJ Wiki account” field
and select OK. Repeat this again entering “NanoJ-VirusMapper” into the “ImageJ
Wiki account” field.

This will add the NanoJ update sites to the list. It is advisable to rename these
“NanoJ” and “NanoJ-VirusMapper” for future reference.

Close the “Manage update sites” window and select “Apply changes”. Restart
Fiji.

After installation you should be able to see VirusMapper in Plugins→NanoJ-VirusMapper.
You are now ready to run VirusMapper!

Required image formats

You can use VirusMapper with any image format supported by ImageJ. However, when
using multiple frames, the frames should first be loaded into an ImageStack, with chan-
nels intercalated. So if you have two channels the first slice in the stack should be channel
1 from your first frame, the second slice should be the corresponding channel 2, the third
slice should be channel 1 from your second frame and so on.

You can put images into stacks like this by opening all the relevant images and
using Image→Stacks→Tools→Concatenate to create a Hyperstack of the frames and
then Image→Hyperstacks→Hyperstack to Stack to create a Stack of the frames. It may
be useful to save this image as a Tiff file for later reuse.

Alternatively, if the raw frames are in one of the supported formats, such as Tiff,
you can use File→Import→Image Sequence.
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3 Extracting viral particles

The first step in the VirusMapper process is to extract individual virus particles from
your images.

To do this, open the relevant image, which must be in the form described above, and
select Plugins→NanoJ-VirusMapper→Extract Viral Structures. First choose where you
wish to save the particles, then this dialog will appear.

Fill in all fields as follows.

Number of channels in dataset The number of different channels you are using.

Reference channel The channel from which maxima will be selected. This should be
the most consistent channel, and ideally particles in this channel will have a central
maximum.

Pre-detection Gaussian blur This option allows you to extract particles from a blurred
frame, which is useful when the reference channel does not have a central maxi-
mum. This can be adjusted to centre particles in the ROIs.

ROI radius (pixels) The radius of the ROI that will be set around each maximum
in pixels. This should be adjusted to make ROIs slightly larger than the largest
particles.
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Number of ROIs to use per frame The number of particles that will be extracted
from each frame. This should be adjusted so that you ideally collect all of the
particles in all frames.

Maximum ROI overlap The degree to which ROIs may overlap, in percent. If parti-
cles are clustered with each other this option can be increased.

Show preview Select to preview the ROIs that will be extracted on the first frame
only. Use this to refine your choice of extraction parameters.

When you have chosen your options select OK to begin the segmentation.

Note: do not change the file names of the particle sets. These names must be in the
form “Viral particles - ChannelX” where X can be anything.
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4 Seed selection

The next step is to choose seed images that will be used in the template matching process
to enable creation of models. These will be images which clearly represent a common
structure that you see in the data, such as a particular orientation of a virus.

You can select a few images which will be averaged together to produce a single aver-
age seed to use in model generation. You can choose seeds for as many of your channels
as you want, but seeds will be aligned with each other based on a single reference channel.

To generate seed images to use in model creation select Plugins→NanoJ-VirusMapper→Generate
Seeds. Choose the folder containing the particles to use. Windows like these will appear.

1. Generate seeds dialog 3. Seed previews

2. Reference particle sequence

Note: at this point, Aparapi can have problems and you may receive an error message
in the Console. If this ever happens, close the message and continue, as VirusMapper
will still be able to run.

1 Generate seeds dialog. This gives you a number of options for seed selection
and is where you input your choice of seeds.

2 Reference particle sequence. This allows you to look through the set of parti-
cles in the reference channel to choose your seeds.

3 Seed previews. This is a preview of the aligned and centred particles from the
frame that you are viewing in the reference particle sequence.
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To begin seed selection you first need to select some initial options. These may be
changed during the seed selection process.

Reference channel The channel that will be fitted with a 2D Gaussian to align and
centre all the other channels.

Generate for channel Select the channels for which you want to generate seeds.

Rotate 90 degrees Select if you want to rotate all seed images by 90 degrees; this may
be useful to have alignment consistent with other models.

Blur radius Some channels may have a shape other than an ellipse, so that fitting with
a 2D Gaussian does not align them consistently. In this case, the image can be
blurred with a Gaussian of chosen radius that should improve the consistency of
alignment. Experiment with different values to find optimal alignment strategy.
A value of 0 applies no blur.

Shift correction When this is selected for a non-reference channel, seeds for that chan-
nel will be separately fitted with a 2D Gaussian and centred accordingly. This can
be useful if, for instance, channels are not perfectly aligned with each other. How-
ever, it can also be very useful to align other channels solely according to the
reference channel. In this case, deselect shift correction.

You can now begin choosing particles to use as seeds. Search through the particle
sequence until you find a suitable particle, then enter the frame number in the Frames
to use box in the Generate seeds dialog. Multiple frame numbers must be separated by
commas.

When you enter frame numbers into this box, other windows will appear.

4. Seed frames and averages
5. Log of similar frames
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4 Seed frames and averages. This is a display of the frames you have selected,
and an average of these frames which you will use as your actual seeds. These will
be displayed for all channels you have selected for seed generation.

5 Log of similar frames. After you select a frame to use as a seed, the log will
suggest some frames which are similar, to assist choosing seeds.

Choose seed images as described. You may wish to adjust options such as blur radius
and shift correction to optimise the process. When you are happy with your average
seed images, name the seeds in the Generate seeds dialog and select OK.
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5 Model generation

To generate models select Plugins→NanoJ-VirusMapper→Generate Model Based On
Seeds. Select the folder containing the particles (not seeds) to use in model creation.
This dialog will appear.

Fill out the settings fields as follows.

Load for channel Select these to choose seeds for the channels you wish to create
models of. You will typically want to use the average seeds that you created in the
previous section. Take care to select these images, not the frames that are also
saved.

Use reference channel for alignment This option aligns multiple channels but by
referring to only one seed. Translations and rotations from the reference channel
template matching are applied to all channels. This can be a useful option in some
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cases such as to compare distribution of a second channel relative to a first but for
model generation as described in the paper this should not be selected.

Square image intensity during template matching Use this to do template match-
ing with the values of both particles and seeds squared. This will accentuate small
differences so may be useful if you are trying to create a model which has some
particular subtle features.

Minimum similarity against model This is the cutoff similarity that will define
which particles are used in creation of your models. Only particles with a sim-
ilarity to the seed greater than this cutoff will be used. It is advisable to choose an
initial value for this and then vary it to observe the effects. You want to include
as many particles as possible that clearly fit the requirements of your model.

Maximum number of iterations The maximum number of times the registration
process will be iterated using the previous model as the new seed. It is advis-
able to leave this at 1 first, to optimise your similarity cutoff, then increase it to
allow the iteration process to occur.

Show.. Choose what elements of the model generation process you wish to see.

Show preview When you have chosen your initial settings select this to begin the
model generation process and preview the results. This can take some time - the
Fiji/ImageJ toolbar should inform you of the progress of the plugin.

Preview the results of your models and optimise the parameters. When you are
happy with your models, name them and select OK.

6 Additional info

Example data

Included in this package under “Example data” is an example dataset of around 4500
vaccinia particles. Channel 1 is the core protein L4 and channel 2 is the lateral body
protein F17. You can use this dataset to try out VirusMapper. Begin with seed selection
to create frontal and sagittal seeds and then proceed with model generation. Alterna-
tively, use the seeds provided to try out model generation. The default settings for most
fields should work well for these data.

Updating VirusMapper

If you installed VirusMapper in Fiji by adding update sites VirusMapper will be updated
automatically by using Help→Update Fiji.

If you installed VirusMapper by copying jars then you can download the latest version
from https://bitbucket.org/rhenriqueslab/nanoj-virusmapper/downloads.
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