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2 Introduction 
The Palette Generator is a free tool for creating color palettes that can be used in FLIR Tools. The 

program displays changes to the palette live when values is changed, added and deleted to give full 

control on the color palette. Basically the Palette Generator linearizes the input value into three 

channels (Red, Green and Blue) which converts the monochrome temperature into colors. When 

palette is generated, the linearization creates a table of RGB colors ranging from 0 to 100% range of 

scaled temperature in image and saves it into FLIR Systems palette folder. 

 

3 License agreement 
This program is a freeware and to be used “as is” by anyone. This program can be used in any situation, 

but is not to be sold or been charged for. Developer of this program is not to be claimed for any missing 

functions, errors or any problems that may occur when using this software. If problems occur, please 

report issues according to section 8 Error Reporting. If disapproval of these terms, do not use this 

program. The license agreement can be changed by software creator. 
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4 Color Palette Overview 
 

 

 

Description of items in picture: 

Item Name Description 

1 Thermal image Displays thermal image with palette 

2 Radiometric Image 
Settings and basic 
functions 

Adjustments and modes adjustment for radiometric images and 
basic functions as Save, New, Open, Undo/Redo and Graph 
Editor 

3 Parameter list Color palette parameters defining the palette. 

4 Color bar Shows the palette ranging from cold to warm (0-100%). 

5 Parameter list sorting Sorts the parameter list. 

6 Special Shades Colors for special shades. 

7 Image Parameters Sets the image temperature range. 

8 MSX Aligner Tool to align the MSX Overlay 

9 Generate Palette Creates the palette file and saves into FLIRs palette folder. 
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5 Working with Palette Generator 
This section will describe the functionality of Palette Generator and how to create the palettes.  

5.1 Open radiometric image 
Radiometric images shot from a FLIR camera can be opened to visualize the color palette. This helps 

to create special tailored palettes for certain images. A radiometric image is a thermal image containing 

radiometric parameters to calculate temperature from the image.  

Click the open image icon or open it from the image menu: 

1. Click on Image -> Load Radiometric JPEG 

 

2. Browse to the radiometric image file and click Load. 

 

5.2 Select radiometric image mode 
The radiometric image can contain visual image, thermal image, MSX and a mix. The following modes 
is available in Palette Generator: 

- MSX (Outlining contrast lines from the visual image into the thermal image) 
- Thermal (Image generated by the temperature values in the image) 
- Visual BW (Visual image in black & white) 
- Visual Color (Visual image in color) 
- Blending (Visual image with a transparent thermal image layer) 

 
The radiometric image mode can be changed from the Image Mode combo box.  

 

 

5.3 Adjust radiometric image mode influence 
Some radiometric image modes can be adjusted. This applies for MSX and Blending modes. The 
amount of the filter influence on the image is adjusted by dragging the slider.   

 
 

5.4 Select radiometric image scaling mode 
The radiometric image can be set to the following scaling modes:  

- Histogram (Image thermal colors distributed from the histogram) 
- Signal (Colors linearized according to sensor raw signal values) 
- Linear (Colors linearized according to temperature values) 
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The radiometric image scaling mode can be changed from the Image 

Scaling combo box. 

5.5 Radiometric image thermal range 
The visible temperature range in an opened radiometric image, can be 

adjusted by setting the upper and lower temperature range in degrees. 

The temperature will be adjusted according to saved thermal unit.  

To automatically set the upper and lower thermal range according to image range, Select Image -> 

Auto Scale. 

 

 

5.6 Importing image from .CSV 
A thermal image exported from FLIR Tools as .csv file (Comma Separated Values file), can be imported 

into Palette Generator to give feedback on how the palette will affect the image. This helps to create 

special tailored palettes for certain images that has been exported to .CSV file. 

1. Click on Image -> Load CSV  
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2. Brows to the exported .csv file and click load. If the .csv file is successfully loaded, the image 

will be displayed in the Thermal Image viewport.  

 

NOTE: Only an image exported as picture and without comments and object parameters will 

successfully be imported into Palette Generator at current version.  

 

5.7 Working with parameters 
The parameter list is an expandable list that contains the parameters needed for linearizing the colors 

for the palette. The parameters consist of two value sets: Input and Color. Input is the value where 

the selected color is represented. The range between two parameters will be gradient between the 

two colors. Example setting the first parameter as red and the next parameter as yellow, will result in 

a gradient going from red -> orange -> yellow.  

 

 

Input parameters has to be a value between 0,0 and 100,0 % representing coldest temperature = 0% 

and warmest temperature = 100%. Input values below 0 will be set to 0, and values above 100 will be 

set to 100. The colors can be changed by double-clicking the color parameter, and a color dialog will 

be displayed where the color can be changed.  

 

5.7.1 Changing parameters 
To change the input value, click the value and enter a new value. When value is entered, the palette 

will be automatically updated.  

To change the color, double click on the color and a color dialog appears. Select color and click OK 

button. The palette is automatically updated with the new color. 
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5.7.2 Add a new parameter to the list 
To add a new parameter, select the new line (lowered) and enter an 

input value. A Color Dialog will be displayed. In the dialog, select color 

and click OK. You can also double click the color cell, and select color 

from the Color Dialog. The input value will then default be set to 100. 

 

5.7.3 Delete a parameter from the list 
To delete a parameter, simply click on the left column and press the Delete 

key on the keyboard. The palette is automatically updated. 

To select multiple parameters in certain range, select the first parameter in 

the row. While holding down Shift-key, select the last row and all rows 

between will be selected.  

To only select certain rows, hold Ctrl-key while mouse clicking on rows to be 

selected. 

5.7.4 Sorting of the parameter list 
The parameter list is automatically sorted by input value by default, which makes the list sort itself 

each time a value or color is changed. To manually sort the list, uncheck Auto Sort check box. Press 

the Sort Parameters button to manually sort the list when automatic sorting is deactivated. The palette 

is always sorted on change so the linearization will work.  

 

 



Copyright Palm Software & Termografi © 2018 - Palette Generator version 1.1 
10 

5.7.5 Auto Spacing 
When Auto Spacing is checked, the parameters in the palette will automatically be adjusted equally. 

Example if the palette contains 5 parameters, the parameter input value will automatically be set to 0, 

25, 50, 75 and 100%. If use tries to change the value, it will be ignored while Auto Spacing is checked. 

NOTE: When the Graph Editor is used, the Auto Spacing is deactivated. 

 

5.7.6 Invert Palette 
To invert the color palette, Click the Invert Palette button. All parameters will be inverted. To go back 

to normal palette, simply press Invert Palette button again. 

 

 

5.7.7 Drag & Drop 
To reorder parameters, the input value can be changed, or the parameter can 

simply be Dragged & Dropped. Simply click on the selection cell outside the 

parameter to be moved, and move the mouse while pressing left mouse button. 

Release the left mouse button when mouse arrow is above the parameter line 

where it is to be moved to.  

NOTE: The Drag & Drop function will interfere differently with the input value 

according to which sorting mode is active. 

- When no Auto Sort or Auto Spacing, the input value will not be changed and only the row 

where the parameter is located will be changed. 

- When Auto Sort is active, the moved input value will be automatically changed to the middle 

value between the parameters above and below and the whole list will be reordered.  

- When Auto Spacing is active, the whole list will be reordered and all values will be adjusted to 

the number of parameters in the palette. 

 

5.8 Special Shades 
The palette contains special shades used in FLIR Tools. To adjust the color for the special shades, simply 

click the color box and select color. For more details about the special shades, go to FLIR Tools User 

Manual. 

 

 



Copyright Palm Software & Termografi © 2018 - Palette Generator version 1.1 
11 

5.9 MSX Aligner 
The MSX Aligner tool allows to move the MSX layer around on the thermal image to achieve correct 

alignment with object of interest. 

The arrow buttons move the MSX layer in the 

direction of the arrow. The speed radio buttons 

specify the amount of pixels the MSX layer is moved 

each click on the arrow button. 

 

 

 
 

5.10 Save thermal image to file 
The thermal image generated from the imported .CSV file, can be 

saved to image file with palette colors applied. To save the image, 

right click the thermal image and select file format. In the Save Dialog, 

select name and path to save the image.  

The following image formats is supported: 
- JPEG 
- PNG 
- BMP 

 

If a radiometric image is opened, the image can be saved with the 

palette and can be post edited in FLIR Tools. To save the radiometric 

image, right click the image and select Save image As Radiometric 

JPEG. In the Save Dialog, select name and path to save the image.  

 

5.11 Undo and redo 
All changes in the palette parameter list can be undone by clicking 

the undo button. To redo again, click the redo button. The 

undo/redo icons will be colored when there is anything that can be 

undone or redone.  

NOTE: When opening or creating a new palette, the undo/redo history is cleared and the action 

cannot be undone.  
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NOTE: When using undo of the parameter list, the change history in the Graph Editor will be cleaned 

and the undo function will load that parameter list into the Graph Editor. 

 

5.12 Generating the palette  
To generate the palette file, enter a palette name into the Name text box and 

press the Generate Palette button. This will create a .pal file with the specified 

name from the Name text box, and save it in the default FLIR palette folder at 

C:\ProgramData\FLIR Systems\Palettes.  

NOTE: The FLIR palette folder path can be changes in the settings. 

 

5.13 Create new, save and load palette save files 
The palette parameters can be saved to a Palm Palette Generator file (.ppg) for later modifications or 

usage. Then all the parameters are saved into the file as shown in the Palette Generator, and can be 

later loaded for modifications. 

 

5.13.1 Create new palette 
Click File -> New to create a new palette. This will clear the parameter list and create a new list with 

default monochrome parameters (black -> white). Any unsaved changes will be discarded. 

 

5.13.2 Save palette configuration 
Click File -> Save to save the palette. If it has not been saved earlier and not been opened, a path has 

to be specified. Browse to the folder to save the palette configuration and click save. If the save has 

been opened or saved earlier, save will overwrite the palette configuration with the changes that is 

performed.  

 

5.13.3 Save As palette configuration 
Click File -> Save As to save the palette configuration to a new file. Browse to the folder to save the 

palette configuration and click save. 

 

5.13.4 Load palette configuration 
Click File -> Open to load a palette configuration. Browse to the folder where the palette configuration 

is and click open. The palette configuration will be loaded into the parameter list and the thermal 

image and color bar will be updated with the loaded configuration. 
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5.14 Importing FLIR palettes 
Already created palettes can be imported into the parameter list 

from .pal file or from opened radiometric image. The algorithm 

searches for the changes in the color curves and adds them to the 

parameter list. Some manual cleaning of imported palette might be 

needed, but the color scaling will be exactly as the palette file 

defines.  

 

5.14.1 Import FLIR palette from file (.pal) 
To import palette from .pal file, select File -> Import FLIR Palette 

(.pal). 

 

5.14.2 Import FLIR palette from image 
The radiometric image is saved with it’s used color palette. This can be imported from the 

radiometric image into Palette Generator. Select File -> Import palette from image. 
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6 Graph Editor 
The Graph Editor provides a different interface for adjusting the colors in the palette. The standard 

palette parameter list makes it easy to add colors to the palette, and the Graph Editor makes it easy 

to perfect them and experiment with the colors. The points on the graph can be moved, deleted and 

new points can be added. The data grid is automatically updated when the graph is modified, and the 

graph is automatically updated when the data grid is modified. 

The X-axis shows the thermal range 0-100% where 0% is cold and 100% is warm. The Y-axis shows the 

color amplitude in byte value (0-255).  

 

A representation of the palette color bar is shown above the graph to easy see what color is in that 

specific range.  

When moving a point on a graph, the point will automatically be added to all three graphs (RGB) to 

create the color, but it will not be visible until the graphs are regenerated from the data grid. When 

the graphs are regenerated, all needed points are added to the graph viewport. A marker on the 

palette color bar indicates the mouse position when moving a point. 

The Graph Editor is located under Edit -> Graph Editor or by clicking the  icon 

 

6.1 Interface 
The Graph Editor have several buttons to change the how the graph manipulation behaves. When a 

function is active, the button background 
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will be black. In this image, the add new point is active and all three RGB graphs are visible.  

To move a point in the graph, press and hold left mouse button and drag the point to the new value. 

The point cannot be higher or lower than the neighbor point in the X-axis. 

 

6.1.1 Graph Edit Mode 
The Graph Edit Mode sets what happens when the right mouse button is clicked on a line or a point.  

When Add Point mode is active  a new point is added on the line that is right mouse clicked.  

When Delete Point mode is active  the point that is right clicked by the mouse is deleted. 

 

6.1.2 Graph Filter 

The Graph Filter allows to show and hide graphs of specific colors.  Default all colors are 

visible. If a button is clicked, the graph for that color is hidden until button is clicked again.  

 

6.1.3 Vertical lock 

The Vertical Lock is used to lock the point movement to the Y-axis.  

 

6.1.4 Multi Selection and Multi Move 
Multiple points can be selected and moved simultaneously. To use select multiple points, press and 

hold left mouse button on an open area, and drag the selection 

box over the points to be selected. When left mouse button is 

released, the selection will be completed. Points on all graphs can 

be selected simultaneously. To move multiple points (points 

selected), press and hold the left mouse button while moving the 

mouse cursor.  

 

To deselect, click on an open area or click on a point that is not selected. 

 

6.2 Undo and redo 

When a change in the Graph Editor is performed, the change is saved in an undo/redo 

history. By clicking the undo or redo button, the graphs are changed to that change in history. The 

parameter list is also updated with the parameters from the graph. If then the graph is changed by 

moving a point or adding a new one, that change will be the last performed change.  

NOTE: It’s important to know that the undo/redo function in the Graph Editor is not the same as in 

the main user interface. Changes in the graph editor will not be added to the main undo/redo 

functionality and will only be added to the Graph Editor. But the latest change is saved to the main 

undo/redo functions.  
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NOTE: If any manual changes in the parameter list (main user interface), the graph is saved to main 

user interface change history and the graph is then updated with the parameter list form the main 

user interface and the Graph Editor change history will be cleared.  

 

7 Settings 
The settings dialog provides user specific settings to be set. The settings are saved in a settings file, 

and are loaded when program starts. 

 

When closing the settings dialog, a message box will ask if the settings are to be loaded into the 

program. If yes, the settings will be overwritten. If no, old settings will be used until the program is 

restarted.  

 

 

7.1 Export Settings 
Export Settings contains settings used during palette export to FLIR Tools. 

 

7.1.1 Palette resolution 
The exported palette file consists of a table of RGB colors. The Palette resolution value describes how 

many rows the table will have with colors. The higher resolution, the smoother the transitions between 

colors will be. More complex palettes will require higher resolution. The resolution cannot be less than 

1. 

Default resolution is 256.  
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7.1.2 Palette export folder 
The Palette export folder path sets where the Palette Generator will save the palette file. This would 

normally be set to FLIR Tools Palette directory. Default path is C:\ProgramData\FLIR 

Systems\Palettes.  

 

7.2 Initial folders 
Initial folders specify what folder that should open when saving/opening palettes, CSV files and images. 

If empty, last opened folder will be used. 

 

7.2.1 Palettes 
Specify initial folder when opening or saving a Palette Generator palette file (.ppg) 

 

7.2.2 CSV import 
Specify initial folder when importing a FLIR Tools CSV file (.csv) 

 

7.2.3 Radiometric image 
Specify initial folder when opening a thermal image containing radiometric data (.jpg | .jpeg) 

 

7.2.4 Visual image 
Specify initial folder when saving image as non-radiometric JPEG, PNG or BMP image file (.jpg | .png | 

.bmp). 
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8 Shortcuts 
List of shortcuts used in the program. 

Description of items in picture: 

Category Shortcuts Description 

File Ctrl + N Create new palette 

Ctrl + O Open Palette Generator file (.ppg) 

Ctrl + S Save Palette Generator file (.ppg) 

Ctrl + Shift + S Save Palette Generator file as (.ppg) 

Alt + F4 Exit Palette Generator application. 

Edit Ctrl + Z Undo change in palette color list 

Ctrl + Y Redo change in palette color list 

Ctrl + G Open/show Graph Editor 

Image Ctrl + R Open radiometric JPEG (.jpg/.jpeg) 

Ctrl + Shift + R Save image as radiometric JPEG ( .jpg) 

Ctrl + T Auto Scale thermal range. 

About F1 Show documentation. 

Graph Editor Ctrl + Z Undo change in graph 

Ctrl + Y Redo change 

A Select add point mode 

D Select delete point mode 

R Toggle red graph filter 

G Toggle green graph filter 

B Toggle blue graph filter 

L Toggle vertical lock mode 

 

9 Support 
For any questions or needed support, go to the Discussion and support forum at 

https://groups.google.com/d/forum/palette-generator/. Link to form can be found in Palette 

Generator at About -> Support. 

10 Error Reporting 
The current state of this program is in BETA mode and errors may occur. If any errors do occur, please 

report them at https://bitbucket.org/napalmy/palette-generator-binary/issues and mark it as “bug”.  

11 Feedback and Improvements 
Feedback and requested improvements is always wanted. Please post them at 

https://bitbucket.org/napalmy/palette-generator-binary/issues and mark them as “enhancement” or 

“proposal”  

 

https://groups.google.com/d/forum/palette-generator/
https://bitbucket.org/napalmy/palette-generator-binary/issues
https://bitbucket.org/napalmy/palette-generator-binary/issues

